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| am Chris Lacinak from AVPreserve, and I'll be talking about the American Archive
Archival Management System (AMS)



AVPreserve is a consulting and software development firm with three primary areas
of focus. On one end of the spectrum we work on collection assessments and
inventories of physical audio, video and film collections akin to the effort that Casey
just talked about. On a different part of the spectrum we consult on digital asset
management, digital preservation and metadata. And our third area, which has me
here today, is software development where we address needs across the entire
spectrum of consulting work we do, targeting custom development where needs are
not being met by existing solutions.



At its core, the AMS is essentially the inventory data set with an application built
around it to serve 3 main users:

- American Archive Admin
- Digitization Service Provider (Crawford)
- Stations

The AMS is the heart of the operation, in that it is where everything and everyone
comes together. At a high level the AMS serves several functions, including:

Search, retrieval and playback

Importing and transforming metadata - from stations and service provider
Registering items (generating GUIDS)

Adding and editing metadata

Tracking and reporting on project status and key metrics

Exporting data

Communication with stations — messaging

It is important to recognize that the AMS is a metadata management system. It does
not manage the media itself. It links to the media and renders it but it is not
managing the media.
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This shows the Administrative Dashboard which highlights

- the number of hours and items digitized

- The percentage of completion

- The number of hours that have been shipped to Crawford but not yet digitized in
order to help maintain adequate backlog

- The number of hours/items digitized by region

- The percentage of scheduled vs. digitized items broken down by Radio and TV

Across the top you see we have 4 main pages consisting of Dashboard, Records,
Stations and Reports
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Scrolling down the Dashboard page we have reporting on a reporting by format of

scheduled and digitized items



Simple Table ~ Full Table  Thumbnails  Flagged
Operation 1-100012,526731 3

I Organization ~ AAGUID ¢ Local ID ¢ Titles

12797.0 Element: #1 Ethel Caffie Austin & Choir S
594

00007346 Program: Beyond Measure: Appalachian
and Econom,

12733.0 Element: 1 Seedtime 5/31/91

00007347 Appalachian

12761.0

00008422 Program: Buftalo Creek Revisited

00007368

12882.0

00008423 Program: Buffalo Creek Revisited

00007369 Program: Beyond Measure: Appalachian

This is an Admin’s main landing page for the Records. There are a few things to note
here:

1. Highlighted in blue is text that says “Assets” to it’s right is a tab called
“Instantiations”. We’ll see more about that in a moment, but think of Assets as a
given piece of content and instantiations as physical manifestations of that content.

2. On the left hand side we have keyword search and faceted browsing. Faceted fields
include:

Date — of all date types in the system

Organization

State

Nomination Status

Generations and more.

An important note about nomination status. You’ll see at the top right of the table a
number in bold. That’s the total number of records in the system. Those are all of the
items that were documented as part of the inventory project. The first wave of
digitization was restricted to 40k hours, and so each station got an allotment of hours
for digitization. The way they identified their priority items for digitization was
through nominating items.



Simple Table  Full Table
state
1-700170
° Operation
Medi Type
Organization Local ID Titles
Moving Image o
Vegas PBS (KLVX) 3925
Vegas PBS (KLVX) 3937 Series : Milennial Moments
Program: #48
Keyword Search »
Vegas PBS (KLVX) 3880 Series : Millennial Moments
Date s Program: #50
Organization » Vegas PBS (KLVX) 3935 Series : Millennial Moments
Program: #50
States »
Vegas PBS (KLVX) 69 Series : Real to Reel
Nomination Status » Program: Las Vegas: Japan's Green Felt Gam
Medi Type »
Physical Format » Vegas PBS (KLVX) a121 Series : Real to Reel
Program: Las Vegas Paper War
Digital Format »
Vegas PBS (KLVX) 3933 Series : Milennial Moments
Generations » Program: 6
Reformatted ¥ Vegas PBS (KLVX) 3895 Series : Millennial Moments
Program: Archival
Vegas PBS (KLVX) 3917 Series : Milennial Moments
mm video-part 1

You’ll see in the top left the filter criteria that has been applied. This is showing all
reformatted/digitized moving image items from the state of Nevada so far. There are
70 of them



Series : Real to Reel
Program: Las Vegas: Japan's Green Felt Gamble

22 INSTANTIATION
Master
69.0 Tape
Physical Fe
Projected

22 INSTANTIATION
Preservation Master
cpo-aacip-22-816m9753 [2Kmud (mediaint
L)

Digital Format: application/mxt
Actual Duration: 0029:22

52 INSTANTIATION
Pro;
CpD-aacip-22-816m9753.h264.mov (media
info)

Digital Format: video/mp4

RS S EdtAsset  Add Instantiation

52 INSTANTIATION

A * Organization: Vegas PBS (KLVX)
Mezzanine

cpb-ascip-22-816ma753 mpeg2.mx! (med
ainto) © Asset Type:  Program
Digital Format: application/mxt

Actual Duration: 0029:22 @ " Title(s):

© * Description: s

And if we click on one of them we’ll go to this detail page.

What is highlighted in blue at the top there is “Asset Information”. This is currently
selected, and this dictates the metadata that shows up beneath the video. This is
descriptive and administrative metadata that applies to all Instantiations.



Physical Format: 3/4 inch videotape
Projected Duration: 00:30:007

INSTANTIATION
Preservation Master
cpb-aacip-22-816m9753 j2k mx! (mediaint
o)

Digital Format: application/mx!

Actual Duration: 00:29:22

INSTANTIATION
Proxy
cpo-aacip-22-816m753 h264.mov (media

A D o Soze e EdtAsset  Add Instantiation

PSTANTIATION Organization: Vegas PBS (KLVX)
Mezzanine

Cpb-aacp-22-816m9753.mpeg2.m (medi

ainto) © Asset Type: Program

Digital Format: application/mxt

Actual Duration: 002922 ©- Titie(s): Series : Real o Reel

Program: Las Vegas: Japan's Green Felt Gamble

Mitch Fox reports. Exterior shot of Dunes hotel. Inter shots of casinos and people gambiing
© " Description:  shots. Holiday International Hotel exterior shot. California hotel exterior. Black and white
footage of Jimmy Hoffa footage. Shot of Alan Dorfman. Shot of Tony

© Publisher:  Vegas PBS,Copyright Holder
Audience Level:
Audience Rating:
© " Local ID: 69 (lag)

American Archive
GUID:

cpb-aacip/22-816m

Scrolling down we see fields ranging from the Local identifier to the Audience Rating.



Series : Real to Reel
Program: Las Vegas: Japan's Green Felt Gamble

W Asset Information

O

I INSTANTIATION
Preservation Master
cpo-aacip-22-816m9753 {2k (mediaint
o
Digital Format: application/mxf
Actual Duration: 0029:22

I3 INSTANTIATION
Proxy
CpD-aacip-22-816m3753 h264.mov (media
info)

Digital Format: video/mp4
Actual Duration: 0029:22

Edit Instantiation  Add Instantiation

I INSTANTIATION
Mezzanine
cpo-aacip-22-816m9753. mpeg2.mxf (medi
ainfo) © Date:
Digital Format: application/mxf
Actual Duration: 002922

© * Instantiation ID: 69,0 (Tape #)

created : 1989-01-24
ssued : 1989-06-01

© * Media Type: Moving Image
© Physical Format: 3/4 inch videotape

© Generation: Master

We have now selected the Master which is the original 3” Umatic tape and the
metadata we see beneath the video now is mostly technical metadata describing this
particular instantiation. The video remains the same throughout of course. It is just

the same proxy to be able to listen and view the content.



Digital Format:
I2 INSTANTIATION
Proxy
cpb-a0ip-22-816m9753.1264.mov (media
info)
Digital Format: video/mp4
(R EditInstantiation  Add Instantiation NOMINATION n
Lt it © * Instantiation ID: 69,0 (Tape #) i
Mezzanine
Cpb-a0p-22-816m9753.mpeg2.m! (medi
reated : 1989-01-
anfo) ODate: S “‘);:902 U?“‘
Digital Format: application/mxt Ssued: 1968
A Actual Duration: 002922
© * Media Type: Moving Image
© Physical Format:  3/4 inch videotape
© Generation:  Master
© " Location: Cabinet #1
© " Duration:  00:30:007
Channel
Ch 1 Full Mix; Ch 2 Full M
Configuration: * v
Event Type Event Date Event Note Event Outcome
inspection 2013-04-18
cleaned 2013-04-18
migration 2013-06-13 gentc

Scrolling down we see a few things

One is the nomination priority 1 over to the right. | talked about this earlier.

The other is the ability to add and edit instantiations.

The other is the table at the bottom. This is what is referred to as provenance or

process history metadata. It tells us about the salient events that have taken place to
a given instantiation. The metadata that is in this table is automatically extracted

from Google Docs at Crawford using the Google Docs API and imported into the AMS.

This is considered important preservation metadata.
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Series . Real to Reel Return << Previous Next >>
Program: Las Vegas: Japan's Green Felt Gamble

W Asset Information

22 INSTANTIATION
Master
69.0(Tape )
Physical Format: 3/4 inch videotape
Projected Duration: 00:30:007

e

I3 INSTANTIATION
Proxy
Cpb-aacip-22-816m3753 h264.mov (media
info)

Digital Format: video/mp4

Actual Duration: 002022 Edit Instantiation  Add Instantiation

2 INSTANTIATION
Mezzanine
cpo-aacip-22-816m9753 mpeg2.mx! (e
ainfo) © Date:
Digital Format: application/mxf
Actual Duration: 0029:22 © * Media Type: Moving Image

© " Instantiation ID:  cpb-aacip-22-816m9753 2k.mxf (mediainfo)

© Digital Format:  applicatior/mxf

© Generation: Preservation Master

This is the preservation master instantiation
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© Generation:

© * Location:

© * Duration:

© File Size:

Standard:

Data Rate:

Tracks:

Channel
Configuration:

Annotation:

Preservation Master

NA

00:29:22

11GiB

OP-1a

54 Mbps

1 video, 1 audio

4 channel

encoded by : OpenCube MXFTk Advanced 2.4.6.0.1

ESSENCE TRACKS

Video

* Track Identifier: 2 (mediainfo)
© * Encoding: (medainfo)
* Track Standard: NTSC
Track Data Rate: 49 Mbps
Frame Rate: 59.940
Bit Depth: 8 bits

Showing the result of importing the Medialnfo file generated by Crawford as part of
their process in order to manage detailed technical information about a given file
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Series . Real to Reel Return << Previous Next >>
Program: Las Vegas: Japan's Green Felt Gamble

W Asset Information

22 INSTANTIATION
Master
69.0(Tape )
Physical Format: 3/4 inch videotape
Projected Duration: 00:30:007

e

I3 INSTANTIATION
Proxy
Cpb-aacip-22-816m3753 h264.mov (media
info)

Digital Format: video/mp4
Aot Duratons (02022 Editinstantiation  Add Instantiation
51 INSTANTIATION
Mezzanine
cpo-aacip-22-816m753 mpeg2.m! (medi
ainfo) © Date: encoded : 2013-06-13

© " Instantiation ID:  cpb-aacip-22-816m9753 2k.mxf (mediainfo)

Digital Format: application/mx!

Actual Duration: 0029:22 © * Media Type: Moving Image

© Digital Format:  applicatior/mxf

© Generation:  Pre: M;

tion

And we also see a mezzanine and proxy file instantiations here too.
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A really critical component of this project was enabling organizations to both import
and refine their metadata. On the importing side

15



Keyword Search »
Simple Table ~ Full Table  Thumbnails  Flagged
Date »
Operation ~ 1-100012,729,667 3
Organization »
Export Results
cr ~ AAGUD ¢+ Local ID ¢ Titles
- Refine Data
Nomination Status » Add Asset MT and 12797.0 Element: #1 Ethel Caffie Austin & Choir S
594
Import Collection
Media Type »
Appalshop, Inc. (WMMT and I fr 00007346 Program: Beyond Measure: Appalachian
Physical Format » Appaishop Films) and Economy
Dighal Formet > Appalshop, Inc. (WMMT and I fqzdx 12733.0 Element: 1 Seedtime 5/31/91
Appalshop Films)
Genorations »
Appalshop, Inc. (WMMT and 46G267mq Program: Beyond Measure: Appalachian
Reformetied Appalshop Films) and Economy
Appalshop, Inc. (WMMT and I 12761.0 Element: 1 Seedtime 6/1/91
Appalshop Films)
\ppalshop, Inc. (WMMT and I 00008422 Program: Buffalo Creek Revisited
Appalshop Films)
Appalshop, Inc. (WMMT and I 00007368 Program: Beyond Measure: Appalachian
Appaishop Films) and Economy
Appalshop, Inc. (WMMT and l 12882.0 Element: #10 FPS: River of Earth, 6 & 7
Appalshop Films)
Appaishop, Inc. (WMMT and I 00008423 Program: Buffalo Creek Revisited
Appaishop Films)
Appaishop, Inc. (WMMT and I 00007369 Program: Beyond Measure: Appalachian
Annalehan Filme) and Economy
hutps.//ams.avpreserve.com| records index¥mint_modal

From within the records page you can go to the Operation menu and select “Import
Collection”



@ Mint =aws

Metadata Interoperability Services

Overviow Data Report  Back to AMS

Import

Select your import method:
@Hup Upioad
Thisis a CSV upload
NTUA FTP Upload
Remote FTPHTTP Upload
OAIURL

From Date (YYYY-MM-DD): To Date (YYYY-MM-DD)

powered by /1 - ©National Technical University of Athens.

This will bring you to this interface which is Mint. Mint is an open source project out
of Europe that is one of the more sophisticated tools out there for importing and
transforming data. You can import CSV or XML

17



Mappings: PBS Tech (CPB AMS RBCORE)
h in ot ofthe
Source Schema Meopiogs R R
ftems | ams:pbcorePublisher: Py
item h
ER——— .
pbceoreldentifier__source__http__amer|
¢ ©
ifior .o
pbeor
ams:instantiationDate: @ ¢
phcoreldontifier2 N
ionLocaton ~ ams +instantiationDimensions: .
Physical. v O 4 InstantiationPhysical
JationDigital Value Mappings
tantiationStandard: Input Value Maps to
~
Input Output
pheoreTitie2 No value mappings defing | Vi
Ppbcoretitietype2 L 4
Betacam
pheoretitied
pbeoretitietyped ams:instantiationFileSize: Be!
pbeoreDescription e TR ieion T obiet Botacam Digital (Digi Beta)
pbcoreassetdate2_issued_ Betacam SP
* O@ i ¢'tantl DVCAM
com 8080 /mint uploadid=10098mapid = 10034

And this shows the mapping interface. On the left we see the the data that was
imported and on the right we see the XSD. This window in front is showing that there
are several functions you can do such as conditional actions, concatenation,
normalization and more.



Mappings: PBS Tech (CPB AMS PBCORE)
Dat

and wh

ok o
XML Proview

itoms

item

pbeoreldentifier_source_http__amer|
instantiationDuration |
instantiationGeneration
pbeoreidentifier2source
pbeoreldentifier2
instantiationLocation
instantiationMediaType
instantiationPhysical
pbeoreTitie!
pbeoreTitle_type_1
pbeoreassetdate_created_

instantiationLanguage
pbeoreTitle2
phcoretitietype2
pbeoretitied
pbeoretitietyped

pbeoreDescription
pbeoreassetdate2_issued_

This shows the result as XSL. This same window will show you the input data, the XSL,
the output or result and validation.
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Vegas PES (KLVX)

Here we see a filtered set of records. If you look in the top left you will see that this is
all results for Nevada, Moving image assets. In the top right of the table we see that
this filtering results in about 6.5k assets. In the case of refinement, this filtering
serves the purpose of selection. So filtering down and then selecting Refine data will
only impact the filtered set.
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Cluster & Edit column "Type of Contract”

This feature helps you find groups of different cell values that might be altemative representations of the same thing. For example,

strings "New York" and
“new york" are very likely to refer to the same concept and just have capitalization differences, and *Godel” and "Godel® probably t

the same person. Find ou
Method | key collision Keying Funs Ngram Size 2 52 clusters found
Cluster Row  Values in Cluster Merge? New Cell Value ) # Choices in Cluster

Size Count

" 1005 o Firm Fixed Price

# Rows in Cluster

| I

Average Length of Choices

i

e 000 ]

Length Variance of Choices

L

Select Al Deselect All Merge Selected & Re-Cluster  Merge Selected & Close  Close

For refinement we integrated Open Refine, an open source data refinement tool
from Google. This is not the American Archive data set in this image, but here we see
an example of normalization. Refine has identified several cells containing similar

data and provides the user with the ability to easily transform them all to a single
expression.
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Reconcile column "film"

Freebase Reconciliation ® Film [ Column Include? As Property
Service rating

This is an example of Open Refine’s ability to integrate with linked open data —in this
case free base — based on named entities within the original data set.

23



EX SRS LOVEIREE
40

Another big issue is exporting, and here the AMS offers two primary mechanisms for
exporting

24



FulTable  Thumbnais  Fiagged
state
1-700f70
L]
~ AAGUID + Local ID ¢+ Titles
o
= Series : A Look Back
3882

Keyword Search » Vegas PBS (KLVX) 3932
Date »

Vegas PBS (KLVX 1813 arquee:
Organization »
States »

Vegas PBS (KLVX 392
Nomination Status »
Media Type » Vegas PBS (KLVX) 3928
Physical Format »
Dightal Format » Vegas PBS (KLVX) 3934
Genorations »

Vegas PBS (KLVX) 3886
Reformatted v

Vegas PBS (KLVX) 3938 Ser

P

p ; indexs_modal

The first is from within the main interface. Again, filtering down to a set of results and
selecting export results will export



° ©00 ams_export_1395088381

# Applications

Desktop

Documents

Reset © Downloads
Google D. | .

Remote Disc

nasd2f274
NASD2F2

(cip-224-04dnckx]
24-08hdrb3s

24-36h18fgn
p-224-38jdfstk

Those records as a bag, using the Baglt specification created by the Library of
Congress and widely adopted as a packaging and exchange method. A bag is simple,
and essentially contains a manifest of all the files it contains and checksums for each
of the files. Each directory is named with it’s GUID and within each directory is a
PBCore XML and and a PREMIS XML document. For those of you that aren’t familiar
with PREMIS it is Preservation Metadata and primarily contains the event type data
that we saw earlier in the item detail showing the events that have taken place to an
item.
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¥ <pbcoreCollection>
¥ <pbcoreDescriptionDocument xmlns:xsi="xsi" xmlns="http://www.pbcore.org/PBCore/PBCoreNamespace.html” xsi:xmlns="htt]
xsi:schemaLocation="http://www.pbcore.org/PBCore/PBCoreNamespace.html http://www.pbcore.org/xsd/pbcore-2.0.xsd">
<pbcoreIdentifier source="http://americanarchiveinventory.org">cpb-aacip/83-49g4fmgx</pbcoreIdentifier>
<pbcoreldentifier source="KUED">1288</pbcoreldentifier>
<pbcoreTitle>Ancient of Days</pbcoreTitle>
v<pbcoreDescription descriptionType="Abstract">
3 episodes of "Alexander Schreiner at the Tabernacle Organ"
</pbcoreDescription>
<pbcoreGenre>Music</pbcoreGenre>
v<pbcoreCreator>
<creator>Keith Engar</creator>
<creatorRole>Producer</creatorRole>
</pbcoreCreator>
¥ <pbcoreContributor>
<contributor>Openshaw, Byron</contributor>
<contributorRole>Director</contributorRole>
</pbcoreContributor>
¥ <pbcorePublisher>
<publisher>KUED</publisher>
<publisherRole>Copyright Holder</publisherRole>
</pbcorePublisher>
¥<pbcoreInstantiation>
<instantiationldentifier source="KUED">1288</instantiationIdentifier>
<instantiationPhysical>DVCPRO 25</instantiationPhysical>
<instantiationLocation>KUED Production Archive> Row 11> Unit 1> Shelf 5</instantiationLocation>
<instantiationMediaType>Moving Image</instantiationMediaType>
<instantiationGenerations>Dub</instantiationGenerations>
<instantiationDuration>01:27:48:00</instantiationDuration>
<instantiationChannelConfiguration>Ch 1 Full Mix; Ch 2 Full Mix</instantiationChannelConfiguration>
<instantiationAlternativeModes>N</instantiationAlternativeModes>
v<instantiationExtension>
¥ <extensionWrap>
<extensionElement>AACIP Record Nomination Status</extensionElement>
<extensionValue>Nominated/lst Priority</extensionvValue>
<extensionAuthorityUsed>AACIP</extensionAuthorityUsed>
</extensionWrap>
</instantiationExtension>
</pbcoreInstantiation>
v<pbcoreInstantiation>
<instantiationIdentifier source="mediainfo">cpb-aacip-83-49g4fmgx.h264.mov</instantiationIdentifier>
<instantiationDate dateType="encoded">2013-07-30</instantiationDate>
<instantiationDigital>video/mp4</instantiationDigital>
<instantiationStandard>QuickTime</instantiationStandard>

The other method of exporting data is using web-services that were built based on
GUID, Digitization date, and last modified date in order to retrieve both PBCore and
PREMIS XML output. This is a better method for using automated mechanisms of
export whereas the previous method of export is oriented toward manual export.
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And that’s all | have time for today. Thanks.
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